DDC(8) FreeBSD System Manager's Manual DDC(8)
ddc - DHCP Daemon Control
This command allows the system administrator to control the operation of
the DHCP daemon. If no command is given, ddc will give an overview of all
start Checks if the DHCP daemon is running, if not it will start
stop Checks if the DHCP daemon is running, if so it will stop it.
restart Checks if the DHCP daemon is running, if so it will stop it.
Then it starts the DHCP daemon.
Checks if the configuration is parsed correctly, does not
start nor stop the DHCP daemon.
running Check if the DHCP daemon is running, does not start or stop
All commands return 0 if everything went fine, 1 otherwise.
For some commands (start, stop and restart) you need privileged access.
The non-privileged commands (running and configcheck) still require read-
access to the pid-file and the configuration-files.
Before starting the program, please make sure that the global variables
are filled in correctly. Not having looked at them may result in unex-
Executable of the DHCPD.
/var/run/dhcpd.pid Process id of the DHCP daemon.
/var/db/dhcpd.leases DHCPD client lease database
Configuration file of the DHCP daemon.
Edwin Groothuis, firstname.lastname@example.org (http://www.mavetju.org)
??? December 20, 2000 ???